Home>Community>Q&A

Q & A

15Rogic3.2 Compatibility
2017-05-19 01:38:09Hits : 703
Profile Image Name : saran.lynus
Status : Complete

My Kit works with Rogic3.2 (8port) 2013/14 model, can i use latest Version?

our board will support?

if no, could send me Rogic3.2 (8Port) Download URL?

Thanks. saran

Reply Please check your mail box.

Thank you.
Comment0